Last Updated: April 5, 2018

Prerequisites

Before you can install the CLI, make sure you have installed its prerequisites.

This includes making sure that pip --user installs are part of your shell’s PATH variable. (See the prerequisites page for more details.)

Install the CLI

To do a typical install of the CLI, run the following command:

pip install --upgrade --user globus-cli

See that the CLI is installed:

globus --help

Install in a Virtualenv

We used to recommend this as the only method of installing the CLI.

It is still supported, and if you prefer or are using an older installation, you may want to see the instructions for using a virtualenv.

Updating and Removing

Update

To update your version of the CLI to the latest:

$ globus update

Uninstall

To remove the CLI:

pip uninstall globus-cli

© 2010- The University of Chicago Legal